Войти
Регистрация
Спроси ai-bota
vanuhask12
11.10.2021 02:10
Заполнить одномерный массив случайными числами в диапазоне от -10 до 10. вычислите произведение отрицательных элементов массива
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
dimandra
29.03.2021 02:18
Алфавит некоторого языка состоит из 32 символов.с данного алфавита был составлен текст, который занимает 3 страницы, на каждой странице 20 строк по 10 символов. определите...
влад22771
07.05.2022 02:19
Чему будет равно значение переменной z после выполнения фрагмента программы x := 15; y := 24; x := x div 6 + y mod 5; z := x + y div 7 mod 2;...
шшшшккпеее1
23.06.2022 10:35
Как характеризуются естественные языки.5 характеристик...
summani2005
21.12.2020 19:51
Какая скорость у ленточного носителя при чтении или записи...
vool23
21.12.2020 19:51
Паскаль ввести целое число и определить верно ли что в его записи есть две одинаковые цифры...
папа11111111111111
18.05.2021 23:33
Отметь общее свойство которым текстовая и графическая модель: 1) хранить информацию об объекте 2)имеют общий цвет и размер3) свойством наглядности 4) используются для передачи...
lenka3398
18.05.2021 23:33
Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin n : = 0; s : = 512; while s =0 do begin s : = s -20; n : =...
avamini2007
21.04.2021 11:04
Составить тест в паскале, с оператора case,...
Высплюсенье
21.04.2021 11:04
Даны 2 числа.найти их сумму,если числа равны,и найти их произведение,если числа не равны.написать блок схему и составить программу на паскаль....
Dash528
03.11.2021 17:52
Нарисовать блок схему и составить программу паскаль. x^2-3,если x 5, z= 11x-4,если x =5...
Ответ:
viamell
03.08.2020 21:27
// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
Writeln('П=',a.Where(x->x<0).Aggregate(BigInteger(1),(x,y)->x*y))
end.
Пример
n= 15
-9 1 -6 -2 -9 4 5 -1 6 -6 6 -4 0 5 -10
П=233280
n= 100
4 5 10 -2 9 3 0 7 -2 1 9 -1 -1 -5 -7 5 -4 -6 7 4 -5 10 6 -1 1 -4 -2 5 -6 -10 0 0 -7 -1 -1 7 -6 -1 -3 4 3 -9 7 7 0 -5 7 1 -8 -1 9 6 1 9 6 5 9 1 7 2 -6 6 2 -2 -10 -2 -4 10 6 -3 0 7 8 -8 -10 -7 -7 10 10 -4 0 8 3 6 -8 5 10 -6 4 4 8 4 2 5 -1 8 0 -2 6 -9
П=14271704784175104000000
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота