lavrinenkoll
16.04.2022 21:45

Написать программу, которая будет принимать числа от пользователя до тех пор пока не будет введен ноль. после того как пользователь ввел все числа она должна вывести сумму всех введенных чисел и произведение, возведенное в квадрат. dim a, b, c as single 'c -это произведение 'b- это сумма b = 0 c = 1 for i = 1 to 10000 console.write("введите a= ") a = console.readline if a > 0 and a < 0 then b = b + a c = c * a else b = b ^ 2 c = c ^ 2 end if next console.writeline("b=" & b & "с=" & c) console.readline() что не так? не могу понять.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GenaTurboKrytt
06.10.2020 20:10
Делайте что-то типо
int m = 1;
while(true) // нескончаемый цикл
{
cout << "Enter number: " << endl; // просим ввести число
cin >> m;
if (m == 0) // проверяем равно ли 0
{
// если да(т.е. мы встретили 0), тут делаем  нужные вычисления
break; // и уже потом выходим из цикла
}
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота