Эрбол11111
19.01.2022 01:52

Напишите программу на языке программирования (или составьте алгоритм). дано натуральное число n, целые числа a a an , , 1 2 . определите номер предпоследнего из членов последовательности a a an , , 1 2 кратных 3; если членов, удовлетворяющих данным условиям, нет, то ответом должно быть «нет».

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Jeinm
03.08.2020 14:48
Const n=10;
var a:array[1..n] of integer;
i,k: integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(50);
 write(a[i]:3);
 end;
writeln;
k:=0;
i:=n;
while (i>0)and(k<2) do
 begin
 if a[i] mod 3 = 0 then k:=k+1;
 i:=i-1;
 end;
if k=2 then writeln('Искомый номер = ',i+1)
else writeln('Нет ');
end.

Пример:
22 13 42 48 26 2 18 30 11 31
Искомый номер = 7
0,0(0 оценок)
Ответ:
арма6
03.08.2020 14:48
Код Pascal:

Var
   n,m,i,A:integer;
Begin
Read(n);
m:=0;
i:=0;
For n:= 1 to n do
    Begin
    Read(A);
    if A mod 3 = 0 then
       if n > m then
          Begin
          i:=m;
          m:=n;
          End
    End;
if i = 0 then Write('нет')
else Write(i)
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота