DINA2808061
02.02.2021 09:29

С++ (в применить операторы цикла) 1. написать программу, которая выводит таблицу значений функции у = -2.4*x2+5*x-3 в диапазоне от -2 до 2, с шагом 0.5. 2. часы бьют каждый час, столько раз, сколько времени. написать программу, которая подсчитает, сколько раз пробьют часы за n часов. n – задает пользователь. (часы считать от 0 часов до 24) 3. пользователь открыл счет в банке и положил 1 000 000 грн. под 8% годовых. каждый год он снимает 100 000 грн. выполнить: а) на экран выводить по каждому году; б) рассчитать, через сколько лет деньги на счету закончатся. (в применить операторы цикла)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Alicewonderr
06.10.2020 12:56
#include <iostream>
using namespace std;
int main()
{
    float x = -2;
    do
    {
    cout<<"y("<<x<<") = "<<(-2.4*x*x+5*x-3)<<"\n";
    x+=0.5;
    }
    while(x <= 2);
    return 0;
}

#include <iostream>
using namespace std;

int main()
{
    int N;
    double S = 0;
    cout <<"N = ", cin >> N;
    for(int i = 0; i < N; i++)
        S+=i%24;
    cout <<"S = "<<S;
    return 0;
}

#include <iostream>
using namespace std;

int main()
{
    double S = 1000000;
    int L = 0;
    do
    {
        S*=1.08;
        S-=100000;
        cout<<L<<": "<<S<<'\n';
        L++;
    }while(S > 0);
    cout <<"Kol-vo let = "<<L;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота