cherrychampagne
06.12.2020 07:19

Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна разрешать ввод одинаковых чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Pussyellien
06.10.2020 11:37
Вот листинг: 

"if freedom is outlawed, only outlaws will have freedom." © TSRh

Напишите программу по последовательному вводу пяти различных чисел чисел. причём программа не должна
0,0(0 оценок)
Ответ:
AzilotikGame
06.10.2020 11:37
Const
   N = 5;
Var
   P:array[1..N] of integer;
   C,i,j,B:integer;
Begin
WriteLn('Введите пять целых чисел');
For i:=1 to N do
    Begin
    Repeat
    B:=0;
    Read(C);
    For j:= 1 to i-1 do
        if P[j] = C then B:=j;
    if B > 0 then WriteLn('Число ',P[B],' уже было'#13'Попробуйте ещё раз')
    else P[i]:=C;
    Until B = 0;
    End;
WriteLn('Полученная последовательность');
For i:= 1 to N do Write(P[i],' ')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота