Viktoria070804
20.09.2022 15:49

23 ! напишите программу, которая в последовательности натуральных чисел определяет количество нечетных чисел, кратных 3. программа получает на вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два число: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Camilla007
06.10.2020 09:44
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  for i:=1 to 1000 do;
    begin
      read (x);
      if (x mod 2 <> 0) and (x mod 3 = 0) then k:=k+1;
      if x=0 then begin
        break
      end;
    end;
  write (i-1,' ',k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота