Вкниге на одной странице помещается k строк. написать программу в паскале которая по номеру строки в тексте выводит на какой странице она находится и на какой строке.
Если на странице k строк, то первая строка на первой странице имеет номер 1, на второй k + 1, на третьей 2k + 1, а четвертой 3k + 1 и т.д. Значит, если есть строка с номером x, то уже (x - 1) div k страниц полностью заполнены, эта строка находится на ((x - 1) div k + 1)-ой странице на ((x - 1) mod k + 1)-ом месте.
var k, x: integer; begin read(k, x); write((x - 1) div k + 1, ':', (x - 1) mod k + 1) end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку