nataliy6578
20.07.2021 09:54

Паскаль написать программу которая по введенному четырехзначному числу выводит сумму его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Pustynya
06.10.2020 07:08
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var t:=Abs(ReadInteger('n='));
  var s:=0;
  while t>0 do begin
    s:=s+t mod 10;
    t:=t div 10
    end;
  Writeln('Сумма цифр равна ',s)
end.

Пример
n= 3048
Сумма цифр равна 15

Замечание: число не обязательно должно быть четырехзначным и не обязательно положительным.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота