schooll2
15.05.2023 21:02

Напишите программу на языке паскаль. надо заменить меньшее из двух данных чисел на их среднее арифметическое а большее из них на среднее .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nikiton22877
06.10.2020 04:47
Var
  a, b,sa,sg: real;

begin
  write('Введите a ');readln(a);
  write('Введите b ');readln(b);
  sa:=(a + b) / 2;
  sg:=sqrt(a * b);
  if a < b then begin
    a := sa;
    b := sg;
  end
  else begin
    a := sg;
    b := sa;
  end;
  writeln('a= ', a:0:2, ' ', 'b= ', b:0:2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота