ABAYMALGAZHDAROvvv
14.11.2021 20:09

Написать программу в паскале в массиве а (15) целых чисел поменять местами 5 и 13 элементы. вывести начальный и изменены массивы в строку через два пробела.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
llizka094
06.10.2020 02:21
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(15,-50,50); a.Println('  ');
  Swap(a[4],a[12]); // индексы от нуля
  a.Println('  ')
end.

Пример
40  28  18  1  35  -50  13  17  40  7  -48  46  -12  -9  50
40  28  18  1  -12  -50  13  17  40  7  -48  46  35  -9  50
0,0(0 оценок)
Ответ:
yanademchenko38
06.10.2020 02:21
program fff;
const
  n = 15;
var
  arr: array[1..n] of integer;
  t : integer;
begin
  for t := 1 to n do begin
    arr[t] := random(101);
    write(arr[t], '  ');
  end;
  writeln();
  t := arr[5];
  arr[5] := arr[13];
  arr[13] := t;
  for t := 1 to n do begin
    write(arr[t], '  ');
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота