sagynnn
01.03.2023 05:22

Напишите программу на языке си. придумайте алгоритм, вводящий три целых числа, который находит второе по величине число, если оно существует

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mariapopova77
06.10.2020 01:45
На C++. Если среднее число равно меньшему или максимальному, то выводит No (вариант с "невозможно определить").

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
 #pragma waring(disable:4996);
 
 int a,b,c,d;
 scanf("%d%d%d",&a,&b,&c);
 if(max(a,b) != min(a,b)){
   d = max(a,b);
 }else{
   printf("NO");return 0;
}
if(d > c && c!= min(a,b)){
 printf("%d",c);return 0;
}
if( d < c){
  printf("%d",d); return 0;

printf("NO");
return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота