Написать программу для решения a) удалить из текста все введенные символы. b) в заданном тексте после каждого знака ‘–’ и перед каждым таким знаком вставить пробел, если его там нет.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
IrishkaKoteika2689
12.07.2020 15:04
Var
  s, s_rej, s2: string;
  i: integer;

begin
  Write('Введите текст: '); Readln(s);
  Write('Введите исключаемые символы ПОДРЯД: '); Readln(s_rej);
  s2 := '';
  for i := 1 to Length(s) do
    if Pos(s[i], s_Rej) = 0 then s2 := s2 + s[i];
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст: Пример текста, из которого будут исключены гласные буквы
Введите исключаемые символы ПОДРЯД: аеёиоуэюя
Обработанный текст: Прмр ткст, з ктрг бдт склчны глсны бквы

var
  s, s2: string;
  i: integer;
  c:array of string;

begin
  Write('Введите текст: '); Readln(s);
  s:=Trim(s);
  c:=s.Split('-');
  s2:=Trim(c[0]);
  for i:=1 to Length(c)-1 do
    s2:=s2+' - '+Trim(c[i]);
  Writeln('Обработанный текст: ', s2)
end.

Тестовое решение:
Введите текст:    тестовая   -строка - в ней много-много тире в разных-  преразных вариантах - и в таком даже
Обработанный текст: тестовая - строка - в ней много - много тире в разных - преразных вариантах - и в таком даже
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота