Войти
Регистрация
Спроси ai-bota
Dbrf30122222
06.01.2021 05:51
Паскаль авс.net программы . массивы подсчитайте количество элементов одномерного массива, абсолютная величина которых совпадает со своим номером.
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
736Nikolay11111111
15.05.2022 02:45
Сколько цифр 1 в двоичном представлении десятичного числа 18?...
Yrbаn
15.01.2020 05:47
Какое наименьшее число почтовых марок стоимостью 10.4 и 1 руб. надо наклеить на бандероль,вес которой м грамм? плата за посылку вычисляется следующим образом: за...
Зайчонок512
16.02.2020 14:34
Программисты, заданный текст содержит только цифры и буквы. определить, обладает ли он следующим свойством: текст совпадает с конечным отрезком ряда 0123456789 (например:...
VOLKODAV770
03.02.2021 15:18
Что такое оболочка, и каковы её свойства?...
maksukras
03.02.2021 15:18
У6 коробках 24 свічки. скільки свічок у 8 таких коробках?...
tolkynd17
03.02.2021 15:18
Этот памятник не только осминогу но и человеку. кто этот человек...
nikitkaapalkov
03.02.2021 15:18
Удочка закреплена на берегу. крепление находится на расстояние 0,5м от одного конца удочки и 1,5 м от другого. на сколько опустился длинный конец удочки,если короткий...
Dangssa
03.02.2021 15:18
Мини сочинение о взаимоотношениях в семье на языке. 5 предложений...
evgeniiantonov
03.02.2021 15:18
Во сколько раз число молекул в 270 г углерода больше числа авагадро? молярная масса углерода равна 0,012 кг/моль.с решением ))...
375196albert
03.02.2021 15:18
Вычислить массу алюмокалиевых квасцов kal(so4)2*12h2oкоторая содержит 7,22*10^24 атомов водорода...
Ответ:
ali12ali
05.10.2020 23:31
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadSeqIntegerWhile('Вводите числа, окончание - 0:',x->x<>0).ToArray;
Writeln('Искомое количество: ',a.Where((x,i)->abs(x)=i+1).Count)
end.
Пример
Вводите числа, окончание - 0: 3 2 7 11 -6 3 -7 16 0
Искомое количество: 2
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота