kote03012
10.01.2022 16:19

50 ! напишите программу , которая в последовательности натуральных чисел определяет мин. число, кратное 3. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число кратное 3. кол-во чисел не превыш. 30000. программа должна вывести 1 число - мин. число, кратное 3

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
equillirum
20.08.2020 15:41
Var a,n,min,i:integer;
begin
write('n = ');
readln(n);
min:=999999;
writeln('Вводите числа:');
for i:=1 to n do
 begin
 readln(a);
 if (a mod 3=0)and(a<min) then min:=a;
 end;
writeln('min = ',min);
end.

Пример:
n = 5
Вводите числа:
52
63
80
18
29
min = 18
0,0(0 оценок)
Ответ:
лоартем1
20.08.2020 15:41
Var i,n,min,a:integer;
begin
 assign (input, 'input.txt'); reset(input);
 assign (output, 'output.txt'); rewrite(output);
 readln(n);
 min:=32767;
 for (i):=1 to (n) do
 begin
  read(a);
  if ((a<min)and(a mod 3 =0))
  then
  min:=a;
 end;
 write(min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота