sea131281
15.01.2020 18:29

Написать программу : даны 3 переменные. поменять значения переменных по следующей схеме: a=c, b=a, c=b. , , в программе pascalabc, информатика

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lera784738374
05.10.2020 17:48
Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
A:=C;
B:=A;
C:=B;
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.

Если имеется ввиду, поменять местами переменные в заданном порядке, то вот:

Var
A,B,C:real;
Begin
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
Write('C = ');ReadLn(C);
Swap(A,C);
Swap(B,A);
Swap(C,B);
WriteLn('A = ',A);
WriteLn('B = ',B);
WriteLn('C = ',C);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота