Дан массив целых чисел из 10 элементов вставить число к перед элементами массива кратными заданному числу r ( k и r вводится с клавиатуры)составить программу
Var A:array[1..10] of integer; B:array[1..20] of integer; i,k,r,N:integer; Begin N:=0; Write('k = ');Read(k); Write('r = ');Read(r); if r = 0 then WriteLn('На ноль делить нельзя!') else Begin WriteLn('Введите массив'); For i:= 1 to 10 do Begin Read(A[i]); if A[i] mod r = 0 then Begin N:=N+1; B[N]:=k End; N:=N+1; B[N]:=A[i] End; For i:= 1 to N do Write(B[i],' ') End End.
Const n=10; Var a:array[1..2*n] of integer; i,j,l,k,r:integer; Begin Randomize; for i:=1 to n do begin a[i]:=random(21); write(a[i]:3); end; writeln; Write('k = ');Readln(k); Write('r = ');Readln(r); For i:=n downto 1 do if a[i] mod r = 0 then begin l:=l+1; for j:=n+l-1 downto i do a[j+1]:=a[j]; a[i]:=k; end; for i:=1 to n+l do write(a[i]:3); writeln; End.