Патригг
22.05.2021 17:08

Написать программу которая сумму всех цифр пятизначного числа х который вводится с клавиатуры и определит заканчивается ли эта сумма на три и четная эта сумма или нет информатика 8 класс

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
faets
05.10.2020 15:07
Program n1;
var a: longint;
procedure sumdig(var x: longint);
var s:longint;
begin
s:=0;
while ( x<>0 ) do
begin
s := s + (x mod 10);
x := x div 10;
end;
if s mod 10=3 then writeln('оканчивается на 3')
else writeln('не оканчивается на 3');
if s mod 2=0 then writeln('четная') else
writeln('нечетная');
end;
begin
writeln('введите целое число');
readln(a);
sumdig(a);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота