Lerosha14
26.08.2020 10:16

Составить программу для нахождения наибольшего общего делителя двух натуральных чисел m и n.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
liza1367
12.07.2020 01:33
Pascal

var a,b,i,c,d:integer;
begin
writeln ('Введите два натуральных числа');
readln (a,b);
if (a>0) and (b>0) then begin
if (a=b) then writeln ('НОД = ',a) else begin
if (a>b) then c:=a else c:=b;
for i:=1 to c do begin
if (a mod i=0) and (b mod i=0) then d:=i;
end;
writeln ('НОД = ',d);
end;
end else writeln ('Неверный ввод');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота