Anna2271
24.04.2020 07:51

Напишите программу, которая переводит целое число(возможно,отрицательное) из двоичной системы счисления в десятичную. Перед отрицательными числами ставится знак "-".

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:

# -*- coding: utf-8 -*-

import math

def return_answer(num):

   sys_num_1 = 2 # из двоичной системы

   main_answer = 0

   negative = ""

   if num.startswith("-"):

       num = num[1:]

       negative = "-"

   num_for_arr = 1

   for i in num:

       if i != '0':

           answ = int(i) * sys_num_1 ** int(len(num)-num_for_arr)

           main_answer += answ

       num_for_arr += 1

   return "%s%s" % (negative, main_answer)

def main():

   while True:

       num = input("\nВведите число: ")

       print("\nответ:", return_answer(num))

if __name__ == '__main__':

   main()

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота