Caxapok24
28.06.2020 17:32

На языке паскале составить программу целого числа из десятичного в двоичную

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
RaSyL111
05.10.2020 14:55
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:int64;
  Read(n);
  var s:='';
  var c:=Ord('0');
  while n>0 do begin
    s:=Chr(c+n mod 2)+s;
    n:=n shr 1
    end;
  Writeln(s,'(2)')
end.

Пример
24523
101111111001011(2)
0,0(0 оценок)
Ответ:
Eldar1001
05.10.2020 14:55
Var A:integer;
B,C:String;
Begin
WriteLn('Введите целое число');
ReadLn(A);
While A<>0 do
Begin
Str(A mod 2,C);
B:=C + B;
A:=A div 2;
End;
WriteLn(B);
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота