2003mariasMaria
28.04.2021 15:21

Pascal abcнапишите программу, которая определяет правильность записи целого числа в восьмеричной системе счисления. формат входных данных на вход программы поступает символьная строка. формат выходных данных программа должна вывести ответ 'yes', если строка представляет собой правильную запись целого числа в восьмеричной системе счисления, и 'no', если запись ошибочна.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Nipep
05.10.2020 12:58
Var value, error: integer;
begin
var s:=readstring ('Введите строку: ');
val (s, value, error);
if (error<>0) or ('9' in s) or ('8' in s) then write ('NO') else write ('YES');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота