ЮлияМарченкова
09.05.2022 15:34

Написать программу по информатике! дана непустая последовательность целых чисел, оканчивающаяся отрицательным числом. верно ли, что все элементы последовательности равны между собой?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivanovaizl
05.10.2020 10:56
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Длина последовательности: ');
  var a:=(SeqRandom(n-1,0,1)+(-1)).ToArray; // последовательность 0 и 1
  a.Println;
  if a.Where(x->x>=0).Distinct.Count>1 then
    Writeln('Есть отличающиеся элементы')
  else Writeln('Все элементы равны')
end.

Примеры
Длина последовательности:  4
1 1 1 -1
Все элементы равны

Длина последовательности:  5
0 1 1 0 -1
Есть отличающиеся элементы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота