Милка534535
21.07.2021 14:52

Запишите соотношение, используемое в ниже подпрограмме procedure f(n: integer); begin if n> 1 then begin f(n div 2); end; write ('**'); end; определите, сколько звездочек будет выведено в результате вызова f(7) подпрограммы

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Aieks01
14.08.2020 17:49
Это рекурсивный вызов процедуры.  При первом вызове F(7)  по условию 
if n>1 then ...  будет вызов этой же процедуры    f(n div 2);  или  f(3),  далее,  т.к. 3>1,  то снова будет вызвана процедура  f(3 div 2)  или f(1),  теперь не выполняется условие  n>1,  следовательно, будет выполнен оператор      write ('**');  -  напечатаются две звездочки, после выхода из процедуры продолжится выполнение процедуры при втором вызове - будут напечатаны еще 2 звездочки, затем продолжится выполнение при первом вызове - еще будут напечатаны 2 звездочки.  В результате вызова f(7) будут напечатаны 6 звездочек  .
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота