happycatcom
13.06.2022 17:34

Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с одинаковым значением

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Снежана341
26.08.2020 07:27
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
  if a.Count>a.ToHashSet.Count then
    Writeln('Есть одинаковые элементы')
  else Writeln('Все элементы различны')
end.

Примеры
n= 4
Вводите: 4 2 5 2
Есть одинаковые элементы

n= 4
Вводите: 5 8 -3 0
Все элементы различны
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота