Veteran2211
09.04.2022 22:49

Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
манюня5649
24.04.2020 03:58
Var a,b,x,s:integer;
begin
write('a = ');
readln(a);
write('x = ');
readln(x);
b:=a;
s:=0;
while b>0 do
 begin
 s:=s+b mod 10;
 b:=b div 10;
 end;
writeln('s = ',s);
if s>x
 then writeln('Сумма цифр больше ',x)
 else writeln('Сумма цифр не больше ',x);
end.

Пример:
a = 31854
x = 15
s = 21
Сумма цифр больше 15
0,0(0 оценок)
Ответ:
JEJH
24.04.2020 03:58
#include <iostream>
#include <stdlib.h>
using namespace std;

int main() {
    int a,x,s=0;
    cin >> a >> x;
    for(;abs(a)>0;s+=abs(a)%10,a/=10);
    cout << (s > x ? "more" : "not more") << endl;   
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота