вова2631
11.02.2021 18:24

Написать программу с массивом случайных 5 чисел от -50 до 50, если больше нуля - то сложить их, если меньше нуля - вычесть. (сумма и разность)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
smesh33221
05.10.2020 05:32
Скорее всего так:
const n=5; 
var a:array[1..n] of integer;
i,s,r:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(101)-50;
 write(a[i]:4);
 end;
writeln;
s:=0; r:=0;
for i:=1 to n do
 if a[i]>0 then s:=s+a[i] else r:=r-a[i];
writeln('s = ',s,' r = ',r);
end.

Пример:
Массив A:
29 32 -48 -42 11
s = 72 r = 90
0,0(0 оценок)
Ответ:
dicsi1
05.10.2020 05:32
#include <iostream>
#include <stdlib.h>
#include <ctime>

using namespace std;

int main() {
    int a[5], p = 0, n = 0;
    srand ( time(NULL) ); 
    for (int i = 0 ; i < 5 ; i++) {
        a[i]=rand()%100-50;
        cout << a[i] << ' ';
        if(a[i] > 0) p+=a[i];
        else n-=a[i];
    }
    cout << endl << p << ' ' << n << endl; 
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота