nenovaolya
04.01.2022 14:38

Написать программу, которая - вводит в компьютер с клавиатуры годовые оценки к учеников класса; - подсчитывает и выводит на экран среднюю оценку в классе; - подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
brandt04
05.10.2020 05:24
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ReadArrInteger('Вводите оценки:',k);
  var m:=a.Average;
  Writeln('Средняя оценка по классу: ',m:4:2);
  Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота