Imdoingfinetoday123
26.05.2021 19:57

1. напишите программу на языке pascal: ввести число, если это число отрицательное (например: -5), то программа должна вывести "число -5 отрицательное ", если число положительное (например: 452) то программа должна вывести "число 452 положительное". на оценку 4 еще рассмотреть случай когда вводится число 0 на оценку 5 еще рассмотреть случай, когда используются метки для многократного введения чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
jiohjb
05.10.2020 00:41
//Pascal ABC.Net
Var a:array[1..1000] of longint;n,i:longint;
Begin
writeln('Введите количество чисел');
readln(n);
writeln('Введите числа');
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if (a[i]<0) then writeln('Число ',a[i],' отрицательное')
else if (a[i]>0) then writeln('Число ',a[i],' положительное')
else writeln('Число ',a[i],' равно нулю');
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота