Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
mukhibamuz14
05.10.2020 00:23
Var
  a,b,c:real;
  k:integer;
begin
  Write('Введите три числа через пробел: '); Read(a,b);
  k:=0;
  if a>0 then Inc(k);
  if b>0 then Inc(k);
  if c>0 then Inc(k);
  Writeln('Количество отрицательных чисел ',k)
end.

Пример
Введите три числа через пробел: 23.5 -24 0
Количество отрицательных чисел 1
0,0(0 оценок)
Ответ:
karinka101
05.10.2020 00:23
Program zadacha;

var

a: array[1..3] of real;

i,k: integer;

begin

k:=0;

writeln('vvedite 3 chisla');

for i:=1 to 3 do read(a[i]);

for i:=1 to 3 do begin

if a[i]>0 then k:=k+1;

end;

writeln('kol-vo polojit.chisel =',k);

end.

Нужно составить программу на паскале: дано три числа. найти количество положительных чисел среди них
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота