bulyginaap08na1
16.09.2020 02:11

Написать программу по информатике: найти произведение положительных, сумму и количество отрицательных из 10 введенных целых чисел.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
egorovaesya
04.10.2020 23:55
 program ex; 
var a,k,s,pr,i:integer;mas:array [0..10] of integer; 
begin 
pr:=1; 
for i:=1 to 10 do   
readln(mas[i]); 
 for i:=1 to 10 do   begin   
 if mas[i]>0 then   
  pr:=pr*mas[i]   
 else      s:=s+mas[i]; 
 end; 
 for i:=1 to 10 do  
 begin    
if mas[i]<0 then       k:=k+1;    
end; 
writeln('Произведение=',pr);
 writeln('Сумма=',s); 
writeln('Количество=',k) 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота