Дан массив, содержащий 20 целых чисел из промежутка [-100,100]. напишите программу,позволяющую найти и вывести наименьшее содержщееся в массиве положительное число,десятичная запись которого оканчивается цифрой 7. если таких чисел нет,укажите это
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016 // Внимание! Если программа не работает, обновите версию!
begin var a:=ArrRandom(20,-100,100); a.Println; var b:=a.Where(x->(x>0) and (x mod 10=7)); if b.Count>0 then Writeln('Искомое число ',b.Min) else Writeln('Нет подходящих чисел') end.