Незнайкаа11
04.05.2020 14:15

Составьте программу, которая формирует массив из десяти случайных чисел от -45 до 45 и меняет местами значение первого и последнего элементов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Кириллпронин
20.08.2020 09:28
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(10,-45,45); a.Println;
  Swap(a[0],a[9]); a.Println
end.

Пример
32 -1 21 17 13 11 -7 14 -7 4
4 -1 21 17 13 11 -7 14 -7 32
0,0(0 оценок)
Ответ:
sofizlatich
20.08.2020 09:28
Type mas= Array [1..10] of integer;
var i,M:integer;
a:mas;
begin
randomize;
for i:=1 to 10
do begin
A[i]:=random (-45,45);
write(A[i],' ');
end;
writeln();
A[1]:=M
A[i]:=A[10]; 
A[10]:=M;
for i:=1 to 10
do write(A[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота