vikap888
11.03.2020 19:00

(Python) 1. Петя, Маричка и Аленка получили первые оценки по информатике. Они придумали следующую задачу — у кого самая высокая оценка, тот побеждает.
Данную задачу они дали Сергею. К сожалению, Сергей занят, поэтому ему решать данную задачу.
Входные данные
Первая строка содержит три целых числа p, m, o (1≤p,m,o≤12) — оценки Петрика, Марички и Аленки соответственно.
Гарантируется, что все числа разные между собой.
Выходные данные
Выведите «Petryk», если у Петрика самая высокая оценка среди всех, «Marichka», если у Марички самая высокая оценка среди всех, или выведите «Olenka», если самая высокая оценка у Аленки.
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
Входные данные №1
8 10 12
ответ №1
Olenka
Входные данные №2
7 9 3
ответ №2
Marichka
2.Пете скучно решать простые задачки, где необходимо находить сумму двух чисел, поэтому его преподавательница программирования дала сложную задачу,
которая звучит следующим образом:
Заданы три целых числа a, b и c. Следует определить, существует ли такое число среди них, что оно равно сумме двух других чисел.
Входные данные
Первая строка содержит три целых числа a, b и c (0≤a,b,c≤100).
Выходные данные
Выведите "Yes", если такое число существует, или выведите "No" (без кавычек).
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
Входные данные №1
0 3 3
ответ №1
Yes
Входные данные №2
1 10 15
ответ №2
No
Входные данные №3
12 20 8
ответ №3
Yes

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anuffka
13.01.2020 21:04
//дан целочисленный массив из 30 элементов. Элементы массива могут принимать значения от -10 до 20.
 //Составьте программу, которая подсчитывает и выводит среднюю температуру по всем дням, 
//когда были заморозки. Гарантируется, что хотя бы в один день были заморозки

var i,x,y  : shortint;
    s      : real;
    t      : array [1..30] of shortint;
begin
  randomize;
  For i:=1 to 30 do
    begin
     t[i]:=random (31)-10; //заполняем таблицу случайным образом (в диапазоне от -10 до 20)
     writeln (i,'  ',t[i]); //строка не обязательная просто позволяет увидеть заполненный массив  
   end;
 for i:=1 to 30 do
   begin
     if t[i]<0 then
        begin
         x:=x+t[i];
         y:=y+1;
       end;
   end;
   s:=x/y;
   writeln ('Средняя температура по дням, когда были заморозки ',s:0:2);
end.
0,0(0 оценок)
Ответ:
софика4
14.03.2021 23:26
1. Разобьем условие на части, чтобы было нагляднее.
в числе меньше восьми цифр "И"
     [число кратно 3 "ИЛИ"
          (число содержит 2 "И" число кратно 5)]

2. Условие "в числе меньше восьми цифр" связано с остальной частью выражения по "И", следовательно, оно обязательное и все, что ему не удовлетворяет, должно быть отброшено вместе с этим условием.
Варианты 4) и 6) содержат 8 цифр и отбрасываются.

3. число кратно 3
    "ИЛИ"
          число содержит 2
          "И"
          число кратно 5
Если варианты "число кратно 3" есть, мы их выбираем, а это условие отбрасываем.
Кратны трем числа 1) 69 2) 12 и 7) 15.

4. Остались числа 3) 25, 5) 22 и 8) 55.
Проверяем их на условие
число содержит 2
"И"
число кратно 5
Содержат двойку 3) 25 и 5) 22, но лишь 25 кратно 5 - его и оставляем.

ответ: 1) 2) 3) 7)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота