vfghjufr
26.03.2023 23:04

Написать программу если в массиве (из n чисел) есть хотя бы одна тройка соседних чисел, в которой средний элемент больше своих "соседей", т. е. предшествующего и последующего, то напечатать все элементы, предшествующие элементам последней из таких троек.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ABCD11111111
04.10.2020 22:07
Type mas=Array [1...100] of integer;
var i,n,itre:integer;
a:mas;
begin
readln(n);
for i:=1 to n
do read(A[i]);
for i:=2 to n-1
do if (A[i]>A[i-1]) and (A[i]>A[i+1])
then itre:=i;
for i:=1 to itre-2
do writeln(A[i]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота