ададсжсжэвжю
29.01.2020 11:09

Напишите программу вася у папы силен в . но сейчас папа в командировке, а васе нужно найти все решения такого уравнения: x + y + x∙y = n поскольку вася за долгие годы безделья разучился решать без посторонней , вам предстоит по заданному целому n (0 ≤n≤ 109) найти количество таких пар целых неотрицательных чисел (x, y), чтобы выполнялось требуемое равенство. поспешите, не то все узнают страшную правду о васе.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Cobachka16
20.08.2020 08:56
Var x,y,n,col:integer;
begin
col:=0;
write('число - ');
readln(n);
for x:=0 to n do begin
  for y:=0 to n do begin
  if (x+y+x*y=n) then begin writeln(x,' ',y); col:=col+1; end;
  end;
end;
write('количество - ',col);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота