porshe04
03.04.2021 06:31

Дано n (n больше 0) натуральных чисел. написать программу, определяющую наибольшее среди них. число n вводится перед всеми остальными числами

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
guldanaramazan
25.09.2020 20:16
 var n,i,max:integer; 
     a:array[1..10000] of integer;
begin
randomize;
 writeln('Введите кол.натур. чисел: ');
 read(n); 
 for i:=1 to n do     begin   
a[i]:= random(n*n);
    write(a[i],' ');
      //read(a[i]); //Если нужен ввод с клавиатуры
    end;
    writeln;
    max:=a[1];
  for i:=1 to n do     begin     
if a[i]>= max then       
  begin 
         max:=a[i];
  end;
end;

  writeln('Наибольшее число:', max);

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота