aygul081071
14.01.2022 17:28

Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zheckachernev
08.09.2020 14:59
Begin
var
int one, two;
bool end=false;
readln(one)
readln(two)
if(one=two or one+2=two or one>two)
writwln("пара чисел написана неправильно")
while(end=false)
begin
if (two>one)
begin
one:=one+2;
writeln(one)
else
end=true;
end;
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота