alenajad
11.10.2021 02:10

Напишите программу на языке паскаль, которая будет вычислять наибольший общий делитель для двух целых чисел а) с repeat б) с while

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
0Frozen0
29.05.2020 16:59

а)

var a,b:integer;

begin

read(a,b);

repeat

if a>b then

a:=a-b

else

b:=b-a;

until (a=b);

write(a);

end.

б)

var a,b:integer;

begin

read(a,b);

while (a<>b) do

if a>b then

a:=a-b

else

b:=b-a;

write(a);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота