vitalikpchel
03.12.2021 20:09

Напишите программу которая для заданного числа определит сколько понадобится спичек чтобы выложить все цифры числа входные данные 1 239 результат 2 16

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zaobogdan
04.10.2020 13:12
См. вложенный файл, программа в нём 
0,0(0 оценок)
Ответ:
alina1866
04.10.2020 13:12
var a: array[0..9] of integer:=(6,2,5,5,4,5,6,3,7,6);
    i,s: integer;
    st: string;
begin
   write('число: ');  readln(st);
   s:=0;
   for i:=1 to length(st) do
   s:=s+a[ord(st[i])-48];
   writeln('число спичек = ',s);
end.

  
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота