Lollimil
17.12.2020 06:30

4. Управление циклом break. Напишите программу. Дана последовательность чисел R (1≤R≤20). Среди чисел только одно равно нулю. Определить порядковый номер расположению нуля очень надо

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
// PascalABC.NET 3.0, сборка 1076
type
  Point=record
  x,y:real
  end;
  Line=record
  A,B:Point
  end;
  Triangle=record
  A,B,C:Point;
  sa,sb,sc:real; { длины сторон }
  end;

procedure GetPoint(PointName:char; var M:Point);
begin
  Write('Введите координаты точки ',PointName,'(x,y): ');
  Read(M.x,M.y)
end;

function LineLength(A,B:Point):real;
begin
  LineLength:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;
 
procedure CreateTriangle(var T:Triangle; var l:boolean);
begin
  With T do begin
    GetPoint('A',A);
    GetPoint('B',B);
    GetPoint('C',C);
    sa:=LineLength(B,C);
    sb:=LineLength(A,C);
    sc:=LineLength(A,B);
    l:=(sa+sb>sc) and (sa+sc>sb) and (sb+sc>sa)
  end
end;

function TriangleIsLikes(T1,T2:Triangle):boolean;
var
  k1,k2,k3:real;
begin
  k1:=T1.sa/T2.sa; k2:=T1.sb/T2.sb;
  if k1=k2 then begin
    k3:=T1.sc/T2.sc;
    TriangleIsLikes:=k1=k3
    end
  else
    TriangleIsLikes:=False
end;

var
  T1,T2:Triangle;
  legal:boolean;
begin
  Writeln('*** Первый треугольник ***');
  CreateTriangle(T1,legal);
  if legal then begin
    Writeln('*** Второй треугольник ***');
    CreateTriangle(T2,legal);
    if legal then
      if TriangleIsLikes(T1,T2) then Writeln('Треугольники подобны')
      else Writeln('Треугольники не подобны')
    else Writeln('Треугольник невозможно построить')
    end
  else Writeln('Треугольник невозможно построить')
end.
0,0(0 оценок)
Ответ:
Ksenichka777
10.07.2020 19:07
1. "Школьное" решение

// PascalABC.Net 3.0, сборка 1066
var
  s,s1:string;
  i:integer;
  a:char;
begin
  Write('Введите натуральное число любой длины :'); Readln(s);
  Write('Введите цифру, которую надо удалить: '); Readln(a);
  s1:='';
  for i:=1 to Length(s) do
    if s[i]<>a then s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовый прогон:
Введите натуральное число любой длины :3141592653589793
Введите цифру, которую надо удалить: 5
Результат: 3141926389793

2. Современное решение (так в школе почему-то не учат)

// PascalABC.Net 3.0, сборка 1066
begin
  var s:=ReadString('Введите натуральное число любой длины :');
  var a:=ReadChar('Введите цифру, которую надо удалить: ');
  Write('Результат: ',s.Replace(a,''));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота