lida113
18.12.2021 05:50

Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. программу реализовать двумя при цикла с пред- и пост- условием.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
tari123456
08.09.2020 12:58
Var
    number: integer;
    k: integer;

begin
    repeat
        write('number = ');
        readln(number);
        
        if number < 0 then k := k + 1;
    until number = 0;
    
    writeln('Кол-во отрицательных = ', k);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота