ksun2003
27.02.2023 06:54

С++ или си написать программу с комментариями что для чего, : функция delete(s,n,l) назначение: удаление из строки s подстроки, начиная с позиции n, длиной l (аналогичная библиотечная функция есть в pascal).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Sasha808621
04.10.2020 07:28
//Dev-C++ 5.11

#include <iostream>
#include <string>
using namespace std;

void DeleteStr(string&, int, int);

int main(void)
 {string s;
 int n,l;
 cin>>s>>n>>l;
 DeleteStr(s,n,l);
 cout<<s<<endl;
 return 0;}

void DeleteStr(string &s, int n, int l)
 {for(int i=n;i<s.length();i++) //начинаем удаление с n элемента
 if(i+l<s.length())  //проверка не выходит ли смещение за границы строки
  s[i]=s[i+l];   //если не выходит, просто переносим символ с позиции+l
 else
   s[i]='\0';      //иначе вводим на позицию пустой символ
}

Пример ввода:
Caster 1 4
Пример вывода:
Cr
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота