123451499
05.01.2020 14:55

Решить на паскаль с постусловием дано натуральное число m. написать программу для вычисления первой цифры числа m. входные данные 54321 выходные данные 5. дано натуральное число m. написать программу для вычисления второй цифры числа м(m> 10) входные данные 54321 выходные данные 4.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shoeva02
04.10.2020 05:18
Var
    m, i: integer;
    a: array[1..10] of integer;

begin
    readln(m);
    i := 0;
    repeat
        i := i + 1;
        a[i] := m mod 10;
        m := m div 10;
    until m = 0;
    
    writeln('Первая цифра ', a[i]);
    writeln('Вторая цифра ', a[i - 1]);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота