СашаВай1
29.04.2020 01:42

Дано n последовательных натуральных чисел начиная с 1.написать программу,вычисляющую их среднее арифметическое

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
altynai0504
20.08.2020 01:29
Import java.util.Scanner;
import java.io.*;
public class Sred {
public static void main(String[] args) {
 Scanner in = new Scanner(System.in);
 int n;
 System.out.print("n=");
 n = in.nextInt();
 int[] a = new int[n];
int sum = 0;
 for (int i = 0; i < n; i++) {
  a[i] = in.nextInt();
  sum += a[i];
 }
 float sred = (float)sum / n;
 System.out.printf("Среднее арифметическое: %.1f \n", sred);
 }
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота