Nikita200111
09.04.2021 16:30

Паскаль! напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ещкшсшашсш
04.10.2020 04:19
Var
  n,i:integer;
  s:string;
begin
  Write('Введите натуральное число: '); Read(n);
  Str(n,s);
  for i:=2 to Length(s) do
    if s[i]=s[i-1] then begin
      Writeln('Пара одинаковых цифр-соседей ',s[i]);
      Exit
      end;
  Writeln('В числе нет цифр, имеющих таких же соседей')
end.

Пример
Введите натуральное число: 375422453
Пара одинаковых цифр-соседей 2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота