sedoidenis2000
04.11.2020 15:26

Составить программу вычисления значений функции f (x) = е ^ (- x ) + cos3x на отрезке [a; b] в точках xi = a + ih, где h = (b-a) / m, а = 1, в = 4, м = 10.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fdods2
05.10.2020 17:36
Const a=1; b=4; m=10;
var x,f,h:real; i:integer;
begin
h:=(b-a)/m;
x:=a-h;
for i:=0 to m do
 begin
 x:=x+h;
 f:=exp(-x)+cos(3*x);
 writeln(x:5:1,f:8:3);
 end;
end.

Результат:
  1.0  -0.622
  1.3  -0.453
  1.6   0.289
  1.9   0.984
  2.2   1.061
  2.5   0.429
  2.8  -0.458
  3.1  -0.947
  3.4  -0.681
  3.7   0.129
  4.0   0.862
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота