anastasiabejena
08.04.2021 05:19

Составить программу которая складывает введенные числа (3 числа) program z1; var s: string ; a,b,c,p,r,t,y,z,x,u,o: integer; begin writeln ('ввежите пример '); readln (s); p: =pos('+',s); a : = val (copy(s,1,p-1),a,r); delete (s,1,p); t: =pos('+',s); x: =val (copy(s,1,t-1),y,r); delete (s,1,t); z: = val (copy(s,1,z-1),u,r); o: =a+t+x; writeln ('сумма равна',o); end. вот что получилось но чет не робит исправьте кто может

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ученица999999999
04.10.2020 02:39
Program z1;

var s:string ;
a,b,c,p,r,t,y,z,x,u,o: integer;

begin

writeln ('введите пример ');

readln (s);

p:=pos('+',s);

val (copy(s,1,p-1),a,r);
delete (s,1,p);
p:=pos('+',s);
val (copy(s,1,p-1),y,r);
delete (s,1,p);
val (s,u,r);
o:=a+y+u;
writeln ('сумма равна',o);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота