flinko4
13.03.2021 21:53

Программа на с++.составить программу для проверки утверждения: "результатом вычисления значения выражения x^2+x+41 при x=(0,40), являются простые числа."

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
3482785525
04.10.2020 00:55
#include <stdio.h>

#define left 0
#define right 40

int prime(int x){
  int d = 2;
  while(d < x && x%d != 0) d++;
  return d == x;    
}

int main(){
  int x;
  for(x = left; x <= right; x++)
      if( !prime(x*x + x + 41) ){
          printf("False \n%d^2 + %d + 41 = %d \n", x, x, x*x + x + 41);
          break;
      }
  if(x > right) printf("True \n");
  return 0;    
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота