1Harius1
23.02.2023 18:56

составить программу на СИ, пользователь вводит строку, в которой все заглавные символы которые он введёт будут преобразованы в прописные

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bolshakovatanyoxd2gr
12.12.2020 21:45

Код программы:

#include <locale>

#include <stdio.h>

int main() {

setlocale(LC_ALL, "Russian");

char str[500];

int i;

printf("Введите строку:\n");

fgets(str, 500, stdin);

for (i = 0; i < strlen(str); i++) {

 if (isupper(str[i]))

  str[i] = tolower(str[i]);

}

printf("\nПреобразованная строка: %s", str);

       return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота