Настюся227
24.05.2021 13:41

Дано 4-х значное число в семиричной системе счисления. напишите программу, переводящую это число в десятичную систему. заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MimINL
03.10.2020 22:37
Писал похожую программу , мб пригодитьсяvar cs1,cs2,res,change:integer; TD:string; function FromDec(n,r:longint):string; var s:String; const digit:string[16]='0123456789ABCDEF'; begin s:=''; repeat s:=digit[(n mod r)+1]+s; n:=n div r; until n=0; FromDec:=s; end; function ToDec(n:string;r:longint):longint; var m,i:longint; const digit:string[16]='0123456789ABCDEF'; begin m:=0; while n[1]='0' do delete(n,1,1); for i:=1 to length(n) do m:=m*r+pos(n,digit)-1; ToDec:=m; end; begin writeln('Введите из какой СC:'); repeat readln(cs1); until (cs1>=2) and (cs1<=36); writeln('Введите число в соответствии с CC:'); readln(TD); writeln('Введите в какую CC:'); repeat readln(cs2); until (cs2>=2) and (cs2<=36); writeln('Перевод из ',cs1,' CC --> ',cs2,' CC:'); writeln(FromDec(ToDec(TD,cs1),cs2)); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота